aboutsummaryrefslogtreecommitdiff
path: root/third_party/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/CMakeLists.txt')
-rw-r--r--third_party/CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/third_party/CMakeLists.txt b/third_party/CMakeLists.txt
index 1b7e2f5..886d357 100644
--- a/third_party/CMakeLists.txt
+++ b/third_party/CMakeLists.txt
@@ -12,12 +12,6 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-if(WIN32)
- option(g_force_shared_crt
- "Use shared (DLL) run-time lib even when Google Test is built as static lib."
- ON)
-endif()
-
if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
# Turn off warnings to make gtest happy
set(GTEST_BUILD_FIXES
@@ -252,6 +246,7 @@ set(ENABLE_SPVREMAPPER OFF)
# Tell Glslang to statically link the C Runtime library.
set(LLVM_USE_CRT_DEBUG MTd)
set(LLVM_USE_CRT_RELEASE MT)
+set(LLVM_USE_CRT_RELWITHDEBINFO MT)
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/glslang)
set(CMAKE_CXX_FLAGS ${CXX_BACK})