summaryrefslogtreecommitdiff
path: root/LoopbackApp/app/build.gradle
diff options
context:
space:
mode:
Diffstat (limited to 'LoopbackApp/app/build.gradle')
-rw-r--r--LoopbackApp/app/build.gradle49
1 files changed, 25 insertions, 24 deletions
diff --git a/LoopbackApp/app/build.gradle b/LoopbackApp/app/build.gradle
index ff69f81..a315418 100644
--- a/LoopbackApp/app/build.gradle
+++ b/LoopbackApp/app/build.gradle
@@ -1,37 +1,38 @@
-apply plugin: 'com.android.model.application'
+/**
+ * The default build is with CMake Plugin.
+ * If Android.mk build system is required, src/main/cpp/Android.mk is
+ * a workable, just add hooks to this file to replace cmake at the "cmake"
+ * location.
+ */
-model {
- android {
- compileSdkVersion = 23
- buildToolsVersion = "25.0"
+apply plugin: 'com.android.application'
- defaultConfig.with {
- applicationId = "org.drrickorang.loopback"
- minSdkVersion.apiLevel = 11
- targetSdkVersion.apiLevel = 23
- }
- ndk {
- moduleName "loopback"
- cppFlags.addAll "-I${project.rootDir}/app/src/main/jni".toString(), "-g"
- CFlags.addAll "-I${project.rootDir}/app/src/main/jni".toString()
+android {
+ compileSdkVersion 28
- ldLibs.addAll "OpenSLES", "log"
+ defaultConfig {
+ applicationId 'org.drrickorang.loopback'
+ minSdkVersion 14
+ targetSdkVersion 26
+ externalNativeBuild.cmake {
+ arguments "-DANDROID_STL=c++_static"
+ }
}
+
+ externalNativeBuild {
+ cmake {
+ path 'src/main/cpp/CMakeLists.txt'
+ }
+ }
+
buildTypes {
release {
minifyEnabled false
proguardFiles.add file('proguard.cfg')
}
- debug {
- ndk {
- debuggable true
- }
- }
- } }
-
-
+ }
}
dependencies {
- compile 'com.android.support:appcompat-v7:23.0.1'
+ implementation 'androidx.appcompat:appcompat:1.0.0-rc02'
}