aboutsummaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Neto <dneto@google.com>2017-05-07 14:39:35 +0200
committerDavid Neto <dneto@google.com>2017-05-08 11:15:41 -0400
commit1e84eab7b9a324e34745084ff201ed930bc2a8dc (patch)
tree255fba37aa35a27e29f1ceb94b3e7814b2808d69 /examples/CMakeLists.txt
parentf338d1e7587dfe3790f45a096574de2b4718e9d9 (diff)
downloadeffcee-1e84eab7b9a324e34745084ff201ed930bc2a8dc.tar.gz
Add EFFCEE_BUILD_TESTING to control making tests
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt24
1 files changed, 13 insertions, 11 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index d565361..86f5a0f 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -5,14 +5,16 @@ if(UNIX)
target_link_libraries(effcee-example -pthread)
endif(UNIX)
-add_test(NAME effcee-example
- COMMAND ${PYTHON_EXE}
- effcee-example-driver.py
- ${CMAKE_CURRENT_BINARY_DIR}/effcee-example
- example_data.txt
- "CHECK: Hello"
- "CHECK-SAME: world"
- "CHECK-NEXT: Bees"
- "CHECK-NOT: Sting"
- "CHECK: Honey"
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR})
+if(EFFCEE_BUILD_TESTING)
+ add_test(NAME effcee-example
+ COMMAND ${PYTHON_EXE}
+ effcee-example-driver.py
+ ${CMAKE_CURRENT_BINARY_DIR}/effcee-example
+ example_data.txt
+ "CHECK: Hello"
+ "CHECK-SAME: world"
+ "CHECK-NEXT: Bees"
+ "CHECK-NOT: Sting"
+ "CHECK: Honey"
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR})
+endif(EFFCEE_BUILD_TESTING)