aboutsummaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 47a326c..32cdd29 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -1,9 +1,15 @@
add_executable(effcee-example main.cc)
target_link_libraries(effcee-example effcee)
-if(UNIX)
- target_link_libraries(effcee-example -pthread)
-endif(UNIX)
+if(UNIX AND NOT MINGW)
+ set_target_properties(effcee-example PROPERTIES LINK_FLAGS -pthread)
+endif()
+if (WIN32 AND NOT MSVC)
+ # For MinGW cross-compile, statically link to the C++ runtime
+ set_target_properties(effcee-example PROPERTIES
+ LINK_FLAGS "-static -static-libgcc -static-libstdc++")
+endif(WIN32 AND NOT MSVC)
+
if(EFFCEE_BUILD_TESTING)
add_test(NAME effcee-example