aboutsummaryrefslogtreecommitdiff
path: root/doc/special_examples/CMakeLists.txt
diff options
context:
space:
mode:
authorYi Kong <yikong@google.com>2022-02-25 16:17:02 +0000
committerAutomerger Merge Worker <android-build-automerger-merge-worker@system.gserviceaccount.com>2022-02-25 16:17:02 +0000
commit7cb50013986f04dce5fac87bebf319bb8db37a36 (patch)
treefb979fb4cf4f8052c8cc66b1ec9516d91fcd859b /doc/special_examples/CMakeLists.txt
parent26a30e76965432e5088c271df90759e49d9636a2 (diff)
parent10f298fc4175c1b8537c674f654a070c871960e5 (diff)
downloadeigen-7cb50013986f04dce5fac87bebf319bb8db37a36.tar.gz
Merge changes Iee153445,Iee274471 am: 79df15ea88 am: 10f298fc41
Original change: https://android-review.googlesource.com/c/platform/external/eigen/+/1999079 Change-Id: I3dd349f9a45d37f37441ff7a7742ebe953b70516
Diffstat (limited to 'doc/special_examples/CMakeLists.txt')
-rw-r--r--doc/special_examples/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/doc/special_examples/CMakeLists.txt b/doc/special_examples/CMakeLists.txt
index 101fbc5f9..5b00e8b1a 100644
--- a/doc/special_examples/CMakeLists.txt
+++ b/doc/special_examples/CMakeLists.txt
@@ -3,7 +3,7 @@ if(NOT EIGEN_TEST_NOQT)
if(QT4_FOUND)
include(${QT_USE_FILE})
endif()
-endif(NOT EIGEN_TEST_NOQT)
+endif()
if(QT4_FOUND)
add_executable(Tutorial_sparse_example Tutorial_sparse_example.cpp Tutorial_sparse_example_details.cpp)
@@ -17,9 +17,8 @@ if(QT4_FOUND)
)
add_dependencies(all_examples Tutorial_sparse_example)
-endif(QT4_FOUND)
+endif()
-check_cxx_compiler_flag("-std=c++11" EIGEN_COMPILER_SUPPORT_CPP11)
if(EIGEN_COMPILER_SUPPORT_CPP11)
add_executable(random_cpp11 random_cpp11.cpp)
target_link_libraries(random_cpp11 ${EIGEN_STANDARD_LIBRARIES_TO_LINK_TO})