aboutsummaryrefslogtreecommitdiff
path: root/bench/btl/libs/blaze/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'bench/btl/libs/blaze/CMakeLists.txt')
-rw-r--r--bench/btl/libs/blaze/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/bench/btl/libs/blaze/CMakeLists.txt b/bench/btl/libs/blaze/CMakeLists.txt
new file mode 100644
index 000000000..e99a0855c
--- /dev/null
+++ b/bench/btl/libs/blaze/CMakeLists.txt
@@ -0,0 +1,13 @@
+
+find_package(BLAZE)
+find_package(Boost COMPONENTS system)
+if (BLAZE_FOUND AND Boost_FOUND)
+ include_directories(${BLAZE_INCLUDE_DIR} ${Boost_INCLUDE_DIRS})
+ btl_add_bench(btl_blaze main.cpp)
+ # Note: The newest blaze version requires C++14.
+ # Ideally, we should set this depending on the version of Blaze we found
+ set_property(TARGET btl_blaze PROPERTY CXX_STANDARD 14)
+ if(BUILD_btl_blaze)
+ target_link_libraries(btl_blaze ${Boost_LIBRARIES})
+ endif()
+endif ()