aboutsummaryrefslogtreecommitdiff
path: root/doc/special_examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'doc/special_examples/CMakeLists.txt')
-rw-r--r--doc/special_examples/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/doc/special_examples/CMakeLists.txt b/doc/special_examples/CMakeLists.txt
index 101fbc5f9..5b00e8b1a 100644
--- a/doc/special_examples/CMakeLists.txt
+++ b/doc/special_examples/CMakeLists.txt
@@ -3,7 +3,7 @@ if(NOT EIGEN_TEST_NOQT)
if(QT4_FOUND)
include(${QT_USE_FILE})
endif()
-endif(NOT EIGEN_TEST_NOQT)
+endif()
if(QT4_FOUND)
add_executable(Tutorial_sparse_example Tutorial_sparse_example.cpp Tutorial_sparse_example_details.cpp)
@@ -17,9 +17,8 @@ if(QT4_FOUND)
)
add_dependencies(all_examples Tutorial_sparse_example)
-endif(QT4_FOUND)
+endif()
-check_cxx_compiler_flag("-std=c++11" EIGEN_COMPILER_SUPPORT_CPP11)
if(EIGEN_COMPILER_SUPPORT_CPP11)
add_executable(random_cpp11 random_cpp11.cpp)
target_link_libraries(random_cpp11 ${EIGEN_STANDARD_LIBRARIES_TO_LINK_TO})