aboutsummaryrefslogtreecommitdiff
path: root/unsupported/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'unsupported/CMakeLists.txt')
-rw-r--r--unsupported/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/unsupported/CMakeLists.txt b/unsupported/CMakeLists.txt
new file mode 100644
index 000000000..4fef40a86
--- /dev/null
+++ b/unsupported/CMakeLists.txt
@@ -0,0 +1,7 @@
+add_subdirectory(Eigen)
+add_subdirectory(doc EXCLUDE_FROM_ALL)
+if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
+ add_subdirectory(test) # can't do EXCLUDE_FROM_ALL here, breaks CTest
+else()
+ add_subdirectory(test EXCLUDE_FROM_ALL)
+endif()