aboutsummaryrefslogtreecommitdiff
path: root/unsupported/Eigen/CXX11/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'unsupported/Eigen/CXX11/CMakeLists.txt')
-rw-r--r--unsupported/Eigen/CXX11/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/unsupported/Eigen/CXX11/CMakeLists.txt b/unsupported/Eigen/CXX11/CMakeLists.txt
new file mode 100644
index 000000000..385ed240c
--- /dev/null
+++ b/unsupported/Eigen/CXX11/CMakeLists.txt
@@ -0,0 +1,8 @@
+set(Eigen_CXX11_HEADERS Tensor TensorSymmetry ThreadPool)
+
+install(FILES
+ ${Eigen_CXX11_HEADERS}
+ DESTINATION ${INCLUDE_INSTALL_DIR}/unsupported/Eigen/CXX11 COMPONENT Devel
+ )
+
+install(DIRECTORY src DESTINATION ${INCLUDE_INSTALL_DIR}/unsupported/Eigen/CXX11 COMPONENT Devel FILES_MATCHING PATTERN "*.h")