aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRoland McGrath <roland@redhat.com>2005-11-16 01:33:38 +0000
committerRoland McGrath <roland@redhat.com>2005-11-16 01:33:38 +0000
commit1b8b446a794ac4babfd687ca48de32e5f4aaa539 (patch)
treeb619a87dfff2b1fb667778f2699daa29a77f74c3 /configure.ac
parentfd856b5865368a894c178be0d2ad7285db5b3150 (diff)
downloadelfutils-1b8b446a794ac4babfd687ca48de32e5f4aaa539.tar.gz
2005-11-15 Roland McGrath <roland@redhat.com>
* configure.ac: Add --enable-tests-rpath option. tests/ 2005-11-15 Roland McGrath <roland@redhat.com> * Makefile.am (BUILD_RPATH): New variable. [TESTS_RPATH] (AM_LDFLAGS): Pass -rpath option using that value. (tests_rpath): New variable. (installcheck-local): Pass it to test-wrapper.sh. * test-wrapper.sh: In "installed" format, take yes/no value for elfutils_tests_rpath, which export. When running a test binary for installcheck, exit 77. * test-subr.sh (installed_testrun): When running a test binary for installcheck, exit 77 if $elfutils_tests_rpath = yes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c2140e26..3d30a031 100644
--- a/configure.ac
+++ b/configure.ac
@@ -152,6 +152,11 @@ AM_CONDITIONAL(GCOV, test "$use_gcov" = yes)
AM_CONDITIONAL(BUILD_STATIC, [dnl
test "$use_mudflap" = yes -o "$use_gprof" = yes -o "$use_gcov" = yes])
+AC_ARG_ENABLE([tests-rpath],
+AC_HELP_STRING([--enable-tests-rpath], [build $ORIGIN-using rpath into tests]),
+ [tests_use_rpath=yes], [tests_use_rpath=no])
+AM_CONDITIONAL(TESTS_RPATH, test "$tests_use_rpath" = yes)
+
LIBEBL_SUBDIR="$PACKAGE"
AC_ARG_ENABLE([libebl-subdir],
AS_HELP_STRING([--enable-libebl-subdir=DIR],