aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGao Xiang <hsiangkao@aol.com>2020-12-17 17:06:25 +0800
committerGao Xiang <hsiangkao@aol.com>2020-12-17 22:54:45 +0800
commit51e6ca94fe02d1ee10b822ca28833289b637bfd1 (patch)
tree9b693ded5ad06f97c1c59821780d865ad4431e03 /configure.ac
parentf1f9659e98ea925a100e50332309955f5b2b4234 (diff)
downloaderofs-utils-51e6ca94fe02d1ee10b822ca28833289b637bfd1.tar.gz
erofs-utils: fuse: disable backtrace if unsupported
Let's enable backtrace conditionally since it's a GNU extension. Link: https://lore.kernel.org/r/20201217090625.22738-1-hsiangkao@aol.com Fixes: 5e35b75ad499 ("erofs-utils: introduce fuse implementation") Reviewed-by: Li Guifu <bluce.lee@aliyun.com> Signed-off-by: Gao Xiang <hsiangkao@aol.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d5fdfb8..28926c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,6 +96,7 @@ AC_ARG_VAR([LZ4_LIBS], [linker flags for lz4])
# Checks for header files.
AC_CHECK_HEADERS(m4_flatten([
dirent.h
+ execinfo.h
fcntl.h
getopt.h
inttypes.h
@@ -147,7 +148,7 @@ AC_CHECK_DECL(lseek64,[AC_DEFINE(HAVE_LSEEK64_PROTOTYPE, 1,
#include <unistd.h>])
# Checks for library functions.
-AC_CHECK_FUNCS([fallocate gettimeofday memset realpath strdup strerror strrchr strtoull])
+AC_CHECK_FUNCS([backtrace fallocate gettimeofday memset realpath strdup strerror strrchr strtoull])
# Configure libuuid
AS_IF([test "x$with_uuid" != "xno"], [