aboutsummaryrefslogtreecommitdiff
path: root/fuse/Makefile.am
diff options
context:
space:
mode:
authorLi Guifu <blucerlee@gmail.com>2020-11-27 20:19:06 +0800
committerGao Xiang <hsiangkao@aol.com>2020-11-27 21:21:40 +0800
commit5e35b75ad4992ae69f3ff6adfb21f8b7ad9f6fe9 (patch)
treea004e1d470e00a9884b9b9f32307a1613fced144 /fuse/Makefile.am
parentdeb8c62c351f3fb8af1a1d938c76a9ea9f002b49 (diff)
downloaderofs-utils-5e35b75ad4992ae69f3ff6adfb21f8b7ad9f6fe9.tar.gz
erofs-utils: introduce fuse implementation
Let's add a simple erofsfuse approach, and benefits are: - images can be supported on various platforms; - new unpack tool can be developed based on this; - new on-disk features can be iterated, verified effectively. This commit only addresses reading uncompressed regular files. Other file (e.g. compressed file) support is out of scope here. Note that erofsfuse is an unstable feature for now (also notice LZ4_decompress_safe_partial() was broken in lz4-1.9.2, which just fixed in lz4-1.9.3), let's disable it by default for a while. Link: https://lore.kernel.org/r/20201127121906.3224-1-hsiangkao@aol.com Signed-off-by: Li Guifu <blucerlee@gmail.com> Signed-off-by: Huang Jianan <huangjianan@oppo.com> Signed-off-by: Guo Weichao <guoweichao@oppo.com> Signed-off-by: Gao Xiang <hsiangkao@aol.com>
Diffstat (limited to 'fuse/Makefile.am')
-rw-r--r--fuse/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/fuse/Makefile.am b/fuse/Makefile.am
new file mode 100644
index 0000000..f14f6fd
--- /dev/null
+++ b/fuse/Makefile.am
@@ -0,0 +1,10 @@
+# SPDX-License-Identifier: GPL-2.0+
+# Makefile.am
+
+AUTOMAKE_OPTIONS = foreign
+bin_PROGRAMS = erofsfuse
+erofsfuse_SOURCES = dir.c main.c
+erofsfuse_CFLAGS = -Wall -Werror -I$(top_srcdir)/include
+erofsfuse_CFLAGS += -DFUSE_USE_VERSION=26 ${libfuse_CFLAGS}
+erofsfuse_LDADD = $(top_builddir)/lib/liberofs.la ${libfuse_LIBS} ${liblz4_LIBS}
+