aboutsummaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am33
1 files changed, 30 insertions, 3 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index f21dc35..25a4a2b 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,9 +1,33 @@
# SPDX-License-Identifier: GPL-2.0+
-# Makefile.am
noinst_LTLIBRARIES = liberofs.la
+noinst_HEADERS = $(top_srcdir)/include/erofs_fs.h \
+ $(top_srcdir)/include/erofs/blobchunk.h \
+ $(top_srcdir)/include/erofs/block_list.h \
+ $(top_srcdir)/include/erofs/cache.h \
+ $(top_srcdir)/include/erofs/compress.h \
+ $(top_srcdir)/include/erofs/config.h \
+ $(top_srcdir)/include/erofs/decompress.h \
+ $(top_srcdir)/include/erofs/defs.h \
+ $(top_srcdir)/include/erofs/err.h \
+ $(top_srcdir)/include/erofs/exclude.h \
+ $(top_srcdir)/include/erofs/flex-array.h \
+ $(top_srcdir)/include/erofs/hashmap.h \
+ $(top_srcdir)/include/erofs/hashtable.h \
+ $(top_srcdir)/include/erofs/inode.h \
+ $(top_srcdir)/include/erofs/internal.h \
+ $(top_srcdir)/include/erofs/io.h \
+ $(top_srcdir)/include/erofs/list.h \
+ $(top_srcdir)/include/erofs/print.h \
+ $(top_srcdir)/include/erofs/trace.h \
+ $(top_srcdir)/include/erofs/xattr.h \
+ $(top_srcdir)/include/erofs/compress_hints.h \
+ $(top_srcdir)/lib/liberofs_private.h
+
+noinst_HEADERS += compressor.h
liberofs_la_SOURCES = config.c io.c cache.c super.c inode.c xattr.c exclude.c \
- namei.c data.c compress.c compressor.c zmap.c decompress.c
+ namei.c data.c compress.c compressor.c zmap.c decompress.c \
+ compress_hints.c hashmap.c sha256.c blobchunk.c dir.c
liberofs_la_CFLAGS = -Wall -Werror -I$(top_srcdir)/include
if ENABLE_LZ4
liberofs_la_CFLAGS += ${LZ4_CFLAGS}
@@ -12,4 +36,7 @@ if ENABLE_LZ4HC
liberofs_la_SOURCES += compressor_lz4hc.c
endif
endif
-
+if ENABLE_LIBLZMA
+liberofs_la_CFLAGS += ${liblzma_CFLAGS}
+liberofs_la_SOURCES += compressor_liblzma.c
+endif