aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVictor Zverovich <victor.zverovich@gmail.com>2018-07-14 06:34:20 -0700
committerVictor Zverovich <victor.zverovich@gmail.com>2018-07-14 06:34:20 -0700
commitae4a3945f58b70711f45ae20bbf2770b03ef82ce (patch)
treebfe38e2450ba3a66ec397e241fdaed143f028c52 /CMakeLists.txt
parenta317448bd4e1fb55a102d48a3048172cc955f390 (diff)
downloadfmtlib-ae4a3945f58b70711f45ae20bbf2770b03ef82ce.tar.gz
Revert "Better support for newer CMake's"
This reverts commit 0eb01b832c095c9a9e87d58adb5ed73b987c437e.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e72955f0..78016a98 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,15 +1,12 @@
-cmake_minimum_required(VERSION 3.1.0...3.11)
+message(STATUS "CMake version: ${CMAKE_VERSION}")
-if(${CMAKE_VERSION} VERSION_LESS 3.12)
- cmake_policy(VERSION ${CMAKE_VERSION})
-endif()
+cmake_minimum_required(VERSION 3.1.0)
# Determine if fmt is built as a subproject (using add_subdirectory)
# or if it is the master project.
set(MASTER_PROJECT OFF)
if (CMAKE_CURRENT_SOURCE_DIR STREQUAL CMAKE_SOURCE_DIR)
set(MASTER_PROJECT ON)
- message(STATUS "CMake version: ${CMAKE_VERSION}")
endif ()
# Joins arguments and places the results in ${result_var}.