aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorHaibo Huang <hhb@google.com>2019-01-08 14:14:22 -0800
committerHaibo Huang <hhb@google.com>2019-01-08 14:22:09 -0800
commit79019a0d336efb722a395ed2db4c5d638104494e (patch)
treec53dd801899ade2bca1472885cc513b49469348c /setup.py
parent69c9acab6a81c7bce36329972332cdbd0d11f449 (diff)
downloadfonttools-79019a0d336efb722a395ed2db4c5d638104494e.tar.gz
Upgrade fonttools from 3.31.0 to 3.35.0
Ran `tools/external_updater/updater.sh update fonttools`. Test: builds Change-Id: I40f991612bf5a41fdd90fc298aef7b02e5a283ad
Diffstat (limited to 'setup.py')
-rw-r--r--[-rwxr-xr-x]setup.py17
1 files changed, 16 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index e975f63d..25093cd4 100755..100644
--- a/setup.py
+++ b/setup.py
@@ -39,6 +39,11 @@ extras_require = {
"lxml": [
"lxml >= 4.0, < 5",
"singledispatch >= 3.4.0.3; python_version < '3.4'",
+ # typing >= 3.6.4 is required when using ABC collections with the
+ # singledispatch backport, see:
+ # https://github.com/fonttools/fonttools/issues/1423
+ # https://github.com/python/typing/issues/484
+ "typing >= 3.6.4; python_version < '3.4'",
],
# for fontTools.sfnt and fontTools.woff2: to compress/uncompress
# WOFF 1.0 and WOFF 2.0 webfonts.
@@ -58,6 +63,10 @@ extras_require = {
"python_version < '3.7' and platform_python_implementation != 'PyPy'"
),
],
+ # for graphite type tables in ttLib/tables (Silf, Glat, Gloc)
+ "graphite": [
+ "lz4 >= 1.7.4.2"
+ ],
# for fontTools.interpolatable: to solve the "minimum weight perfect
# matching problem in bipartite graphs" (aka Assignment problem)
"interpolatable": [
@@ -65,6 +74,12 @@ extras_require = {
"scipy; platform_python_implementation != 'PyPy'",
"munkres; platform_python_implementation == 'PyPy'",
],
+ # for fontTools.varLib.plot, to visualize DesignSpaceDocument and resulting
+ # VariationModel
+ "plot": [
+ # TODO: figure out the minimum version of matplotlib that we need
+ "matplotlib",
+ ],
# for fontTools.misc.symfont, module for symbolic font statistics analysis
"symfont": [
"sympy",
@@ -337,7 +352,7 @@ def find_data_files(manpath="share/man"):
setup(
name="fonttools",
- version="3.31.0",
+ version="3.35.0",
description="Tools to manipulate font files",
author="Just van Rossum",
author_email="just@letterror.com",