summaryrefslogtreecommitdiff
path: root/dev-python/unittest2/unittest2-1.1.0-r1.ebuild
diff options
context:
space:
mode:
authorMike Frysinger <vapier@google.com>2015-10-12 23:34:32 -0400
committerMike Frysinger <vapier@google.com>2015-10-12 23:34:32 -0400
commit64b3189079aa6c10a0204880a58df53b36b9f36a (patch)
tree7508f174756528dfe5ad3a359ef24ac3c2baf3f7 /dev-python/unittest2/unittest2-1.1.0-r1.ebuild
parent5d6f128da92287fc0b2643d810ecd96f81ac3aa2 (diff)
parentfbc240f551b32a009511d34ac5c3fd7c15ef82b9 (diff)
downloadgentoo-64b3189079aa6c10a0204880a58df53b36b9f36a.tar.gz
Merge https://github.com/gentoo/gentoo.gitbrillo-m7-releasebrillo-m7-mr-devbrillo-m7-dev
Diffstat (limited to 'dev-python/unittest2/unittest2-1.1.0-r1.ebuild')
-rw-r--r--dev-python/unittest2/unittest2-1.1.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/unittest2/unittest2-1.1.0-r1.ebuild b/dev-python/unittest2/unittest2-1.1.0-r1.ebuild
new file mode 100644
index 0000000000..502d2ed886
--- /dev/null
+++ b/dev-python/unittest2/unittest2-1.1.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="The new features in unittest backported to Python 2.4+"
+HOMEPAGE="https://pypi.python.org/pypi/unittest2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/linecache2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4[${PYTHON_USEDEP}]
+ dev-python/traceback2[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}"
+
+PATCHES=( "${FILESDIR}"/remove-argparse-dependence.patch )
+
+python_test() {
+ "${PYTHON}" -m unittest2 discover || die "tests failed under ${EPYTHON}"
+}