summaryrefslogtreecommitdiff
path: root/media-libs/phat/phat-0.4.1-r1.ebuild
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-02-04 20:35:02 +0100
committerDavid Seifert <soap@gentoo.org>2016-02-04 21:22:47 +0100
commit381859713aa94bc36e5e4dffe65671e4f3f3adf5 (patch)
treefc407b28a6cceac07b3c2cf4fdb5278f35c740b1 /media-libs/phat/phat-0.4.1-r1.ebuild
parentc09fd8b782ee395e5fd3ea21ec889e3a290dd49c (diff)
downloadgentoo-381859713aa94bc36e5e4dffe65671e4f3f3adf5.tar.gz
media-libs/phat: Fix underlinking with x11-libs/libX11
* EAPI=6 * Change SRC_URI and HOMEPAGE (Gentoo-Bug: 537756) * Add missing dev-util/gtk-doc for autoreconf Package-Manager: portage-2.2.27
Diffstat (limited to 'media-libs/phat/phat-0.4.1-r1.ebuild')
-rw-r--r--media-libs/phat/phat-0.4.1-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/phat/phat-0.4.1-r1.ebuild b/media-libs/phat/phat-0.4.1-r1.ebuild
new file mode 100644
index 0000000000..cabb3f35a4
--- /dev/null
+++ b/media-libs/phat/phat-0.4.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils
+
+DESCRIPTION="PHAT is a collection of GTK+ widgets geared toward pro-audio apps"
+HOMEPAGE="https://sourceforge.net/projects/phat.berlios/"
+SRC_URI="mirror://sourceforge/phat.berlios/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11
+ gnome-base/libgnomecanvas"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/gtk-doc"
+
+PATCHES=(
+ "${FILESDIR}/${P}-underlinking.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}