summaryrefslogtreecommitdiff
path: root/x11-wm/aewm
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/aewm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/aewm')
-rw-r--r--x11-wm/aewm/Manifest1
-rw-r--r--x11-wm/aewm/aewm-1.3.12.ebuild52
-rw-r--r--x11-wm/aewm/files/aewm-1.3.12-gentoo.patch63
-rw-r--r--x11-wm/aewm/metadata.xml12
4 files changed, 128 insertions, 0 deletions
diff --git a/x11-wm/aewm/Manifest b/x11-wm/aewm/Manifest
new file mode 100644
index 0000000000..09cacc9dd6
--- /dev/null
+++ b/x11-wm/aewm/Manifest
@@ -0,0 +1 @@
+DIST aewm-1.3.12.tar.bz2 36677 SHA256 20edc3e57630fe2e0ca6139ce5769bd10a149f59a16f45acdf9bc64268fd59de SHA512 69435edf1ba99661464221070ab6708a875056d244ee73b2eba1ed2beefba52ac2418d37e0d8b9f0c7c8a382e9d8740215b9c7098eca4f39cdf73b3c894125f1 WHIRLPOOL 077486fa4bcf46247915b40ed483c753c11ae1faa8b01b783bfe758d35f4d113cb99626ddea9afdb855358d44042e30e490389c12fb9ee3b8e3c37ada89279ed
diff --git a/x11-wm/aewm/aewm-1.3.12.ebuild b/x11-wm/aewm/aewm-1.3.12.ebuild
new file mode 100644
index 0000000000..bd4b3c0317
--- /dev/null
+++ b/x11-wm/aewm/aewm-1.3.12.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A minimalistic X11 window manager"
+HOMEPAGE="http://www.red-bean.com/~decklin/software/aewm/"
+SRC_URI="${HOMEPAGE}${P}.tar.bz2"
+
+LICENSE="MIT 9wm"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i -e '/^font/s|".*"|"fixed"|g' doc/aewmrc.ex || die
+ sed -i -e 's|skill|pkill|g' doc/clientsrc.ex || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ MANDIR="${D}/usr/share/man/man1" \
+ XROOT="/usr" \
+ install
+
+ dodoc NEWS README
+}
diff --git a/x11-wm/aewm/files/aewm-1.3.12-gentoo.patch b/x11-wm/aewm/files/aewm-1.3.12-gentoo.patch
new file mode 100644
index 0000000000..6cc02f4560
--- /dev/null
+++ b/x11-wm/aewm/files/aewm-1.3.12-gentoo.patch
@@ -0,0 +1,63 @@
+--- a/Makefile
++++ b/Makefile
+@@ -6,12 +6,12 @@
+ XROOT = /usr/X11R6
+
+ # Uncomment to enable Shape extension support
+-#OPT_WMFLAGS += -DSHAPE
++OPT_WMFLAGS += -DSHAPE
+ #OPT_WMLIB += -lXext
+
+ # Uncomment to add Xft support
+-#OPT_WMFLAGS += -DXFT `pkg-config --cflags xft`
+-#OPT_WMLIB += `pkg-config --libs xft` -lXext
++OPT_WMFLAGS += -DXFT $(shell $(PKG_CONFIG) --cflags xft xext)
++OPT_WMLIB += $(shell $(PKG_CONFIG) --libs xft xext)
+
+ # Uncomment for debugging (abandon all hope, ye who enter here)
+ #OPT_WMFLAGS += -DDEBUG
+@@ -46,7 +46,7 @@
+
+ X11FLAGS = -I$(XROOT)/include
+ WMFLAGS = $(X11FLAGS) $(OPT_WMFLAGS)
+-GTKFLAGS = `pkg-config --cflags gtk+-2.0`
++GTKFLAGS = $(shell $(PKG_CONFIG) --cflags gtk+-2.0)
+
+ $(PLAINOBJ): %.o: %.c
+ $(CC) $(CFLAGS) -c $< -o $@
+@@ -60,28 +60,28 @@
+ $(GTKOBJ): %.o: %.c
+ $(CC) $(CFLAGS) $(GTKFLAGS) -c $< -o $@
+
+-X11LIB = -L$(XROOT)/lib -lX11
++X11LIB = $(shell $(PKG_CONFIG) --libs x11)
+ WMLIB = $(X11LIB) $(OPT_WMLIB)
+-GTKLIB = `pkg-config --libs gtk+-2.0`
++GTKLIB = $(shell $(PKG_CONFIG) --libs gtk+-2.0)
+
+ $(PLAINBIN): %: %.o
+- $(CC) $^ -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o $@
+
+ $(X11BIN): %: %.o
+- $(CC) $^ $(X11LIB) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ $(X11LIB) -o $@
+
+ $(WMBIN): %:
+- $(CC) $^ $(WMLIB) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ $(WMLIB) -o $@
+
+ $(GTKBIN): %: %.o
+- $(CC) $^ $(GTKLIB) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ $(GTKLIB) $(X11LIB) -o $@
+
+ AEMAN = aewm.1x aeclients.1x
+ AERC = aewmrc clientsrc
+
+ install: all
+ mkdir -p $(BINDIR) $(MANDIR) $(CFGDIR)
+- install -s $(ALLBIN) $(BINDIR)
++ install $(ALLBIN) $(BINDIR)
+ for i in $(AEMAN); do \
+ install -m 644 doc/$$i $(MANDIR); \
+ gzip -9 $(MANDIR)/$$i; \
diff --git a/x11-wm/aewm/metadata.xml b/x11-wm/aewm/metadata.xml
new file mode 100644
index 0000000000..aeb17f4fb9
--- /dev/null
+++ b/x11-wm/aewm/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>jer@gentoo.org</email></maintainer>
+ <longdescription>
+ aewm is a minimalist window manager for X11. It has no nifty features,
+ but is light on resources and extremely simple in appearance. It should
+ eventually make a good reference implementation of the ICCCM. A few
+ separate programs are included to handle running programs, switching
+ between windows, etc.
+ </longdescription>
+</pkgmetadata>