aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLei Xu <lei@cloudera.com>2014-07-24 23:57:09 -0700
committerLei Xu <lei@cloudera.com>2014-07-24 23:57:09 -0700
commit3460bf1aa66d773b9bfb0a2a01f918977a506f43 (patch)
tree8f8f87d6f562e1daeeb01a00c8b3e1242418a636 /CMakeLists.txt
parentf1e1ccafcc6f4565f907cc5d0592b24fe0aae5b4 (diff)
downloadgoogle-benchmark-3460bf1aa66d773b9bfb0a2a01f918977a506f43.tar.gz
Fixed compiling on Mac 10.9.3 with g++-4.8, clang or system c++
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 06de886..53731c1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,7 @@ set_directory_properties(properties EP_PREFIX "${CMAKE_BINARY_DIR}/third_party")
ExternalProject_Add(googletest
URL "https://googletest.googlecode.com/files/gtest-1.7.0.zip"
SOURCE_DIR "${CMAKE_BINARY_DIR}/third_party/gtest"
+ CMAKE_ARGS "-DCMAKE_CXX_COMPILER=${CMAKE_CXX_COMPILER}"
INSTALL_COMMAND "")
ExternalProject_Get_Property(googletest source_dir)
include_directories(${source_dir}/include)