aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Fiselier <eric@efcs.ca>2015-03-12 20:27:29 -0400
committerEric Fiselier <eric@efcs.ca>2015-03-12 20:27:29 -0400
commit66bf7c8f7194ecd3b9f6426ca3b4807e8a8996a2 (patch)
tree50989e2163164fba9506df33244e0eb0c4fe292b /CMakeLists.txt
parentf022d780ebf71a842418cf3e210e68efbc7a49c3 (diff)
downloadgoogle-benchmark-66bf7c8f7194ecd3b9f6426ca3b4807e8a8996a2.tar.gz
add floating point comparison warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b4a36bd..947239b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,6 +39,7 @@ add_cxx_compiler_flag(-Wshadow)
add_cxx_compiler_flag(-Werror)
add_cxx_compiler_flag(-pedantic-errors)
add_cxx_compiler_flag(-Wshorten-64-to-32)
+add_cxx_compiler_flag(-Wfloat-equal)
# TODO(ericwf): enable this for g++
#add_cxx_compiler_flag(-Wzero-as-null-pointer-constant)
# Release flags