aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Clarkson <mattyclarkson@gmail.com>2014-08-01 15:00:43 +0100
committerMatt Clarkson <mattyclarkson@gmail.com>2014-08-01 15:02:32 +0100
commitc927845d5ad5344cb681598001d2234cefa61145 (patch)
treeb08f7112ae4f5ef60c74c3d4d71248f3f3a8c66a /CMakeLists.txt
parentd591edf5139e0b160bfedc88c1e1632d21fc9f28 (diff)
downloadgoogle-benchmark-c927845d5ad5344cb681598001d2234cefa61145.tar.gz
get_git_version CMake function
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt29
1 files changed, 6 insertions, 23 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 017a8cd..d6b4fb6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,10 @@
cmake_minimum_required (VERSION 2.8)
project (benchmark)
+# Make sure we can import out CMake functions
+list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
+
+# We need threads in this project
find_package(Threads REQUIRED)
# Import and build Google Test
@@ -39,31 +43,10 @@ if(${CMAKE_SYSTEM_PROCESSOR} MATCHES "x86")
endif()
# Read the git tags to determine the project version
-execute_process(COMMAND git describe --match "v[0-9]*.[0-9]*.[0-9]*" --abbrev=8
- RESULT_VARIABLE status
- OUTPUT_VARIABLE GIT_VERSION
- ERROR_QUIET)
-if(${status})
- set(GIT_VERSION "v0.0.0")
-else()
- string(STRIP ${GIT_VERSION} GIT_VERSION)
- string(REGEX REPLACE "-[0-9]+-g" "-" GIT_VERSION ${GIT_VERSION})
-endif()
-
-# Work out if the repository is dirty
-execute_process(COMMAND git update-index -q --refresh
- OUTPUT_QUIET
- ERROR_QUIET)
-execute_process(COMMAND git diff-index --name-only HEAD --
- OUTPUT_VARIABLE GIT_DIFF_INDEX
- ERROR_QUIET)
-string(COMPARE NOTEQUAL "${GIT_DIFF_INDEX}" "" GIT_DIRTY)
-if (${GIT_DIRTY})
- string(CONCAT GIT_VERSION ${GIT_VERSION} "-dirty")
-endif()
+include(GetGitVersion)
+get_git_version(GIT_VERSION)
# Tell the user what versions we are using
-message("-- git Version: ${GIT_VERSION}")
string(REGEX MATCH "[0-9]+\\.[0-9]+\\.[0-9]+" VERSION ${GIT_VERSION})
message("-- Version: ${VERSION}")