aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Kennelly <ckennelly@ckennelly.com>2014-04-23 00:47:07 -0700
committerChris Kennelly <ckennelly@ckennelly.com>2014-04-23 00:47:07 -0700
commite38fde6450f5b102a9f3d3842a9286de4b678a5e (patch)
tree7ffbf2d1f6a5d5ed8474a697237ab86407f1d748 /CMakeLists.txt
parent9b5ece6ece56d2c8115dd3c8b8ad63b1d1752601 (diff)
downloadgoogle-benchmark-e38fde6450f5b102a9f3d3842a9286de4b678a5e.tar.gz
Setup targets from each directory, rather than the top-level.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 3 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 09fe0b2..e4c6aa2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -30,19 +30,6 @@ include_directories(${PROJECT_SOURCE_DIR}/include)
include_directories(${PROJECT_SOURCE_DIR}/src)
# Build the targets
-FILE(GLOB SOURCE_FILES "src/*.cc")
-add_library(benchmark STATIC ${SOURCE_FILES})
-
-add_executable(benchmark_test test/benchmark_test.cc)
-target_link_libraries(benchmark_test benchmark ${CMAKE_THREAD_LIBS_INIT})
-
-# Install target (will install the library to specified CMAKE_INSTALL_PREFIX variable)
-INSTALL(
- TARGETS benchmark
- ARCHIVE DESTINATION lib
- LIBRARY DESTINATION lib
- COMPONENT library)
-INSTALL(
- DIRECTORY "${PROJECT_SOURCE_DIR}/include/benchmark"
- DESTINATION include
- FILES_MATCHING PATTERN "*.*h") \ No newline at end of file
+enable_testing()
+add_subdirectory(src)
+add_subdirectory(test)