aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDominic Hamon <dma+github@stripysock.com>2014-10-11 15:52:50 -0700
committerDominic Hamon <dma+github@stripysock.com>2014-10-11 15:52:50 -0700
commite6107a781c35f5e0a366e526631ea8cef8f246c5 (patch)
tree5dc375231b34d9a20fccf4c09527b764b4ebaab6 /CMakeLists.txt
parentcfb34b5957ebe1873ba58559a23002f9f4a7e521 (diff)
downloadgoogle-benchmark-e6107a781c35f5e0a366e526631ea8cef8f246c5.tar.gz
Fix #50 by using nullptr and adding stricter warning.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 340055c..ec98408 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -40,6 +40,7 @@ add_cxx_compiler_flag(-Wall)
add_cxx_compiler_flag(-Wshadow)
add_cxx_compiler_flag(-Werror)
add_cxx_compiler_flag(-pedantic-errors)
+add_cxx_compiler_flag(-Wzero-as-null-pointer-constant)
# Release flags
add_cxx_compiler_flag(-fno-strict-aliasing RELEASE)