aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDominic Hamon <dominic+github@google.com>2020-01-30 13:29:17 +0000
committerDominic Hamon <dominic+github@google.com>2020-01-30 13:29:17 +0000
commit5ac80de0379ae1153ca6ef141df89ecf53bf1110 (patch)
treeab3a3cbf5cf0f576d3bb6b1625f70c4bb13538bf /CMakeLists.txt
parentdaff5fead3fbe22c6fc58310ca3f49caf117f185 (diff)
downloadgoogle-benchmark-5ac80de0379ae1153ca6ef141df89ecf53bf1110.tar.gz
Disable pedantic warnings and errors until googletest/gmock is fixed
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8cfe125..72466f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -143,8 +143,9 @@ else()
add_cxx_compiler_flag(-Werror RELEASE)
add_cxx_compiler_flag(-Werror RELWITHDEBINFO)
add_cxx_compiler_flag(-Werror MINSIZEREL)
- add_cxx_compiler_flag(-pedantic)
- add_cxx_compiler_flag(-pedantic-errors)
+ # Disabled until googletest (gmock) stops emitting variadic macro warnings
+ #add_cxx_compiler_flag(-pedantic)
+ #add_cxx_compiler_flag(-pedantic-errors)
add_cxx_compiler_flag(-Wshorten-64-to-32)
add_cxx_compiler_flag(-fstrict-aliasing)
# Disable warnings regarding deprecated parts of the library while building