aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Reinking <alex_reinking@berkeley.edu>2020-01-31 02:16:25 -0800
committerGitHub <noreply@github.com>2020-01-31 10:16:25 +0000
commite5ea03ce07997620980636b3ee7e6117d68bc6ad (patch)
tree27994c40279aabd781e8e5e802fe780218b9ce0f /CMakeLists.txt
parent5ac80de0379ae1153ca6ef141df89ecf53bf1110 (diff)
downloadgoogle-benchmark-e5ea03ce07997620980636b3ee7e6117d68bc6ad.tar.gz
Fix cxx03 standard selection, option override in CMake 3.13+. Fixes #933 (#934)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 72466f9..67c0b70 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,6 +6,7 @@ foreach(p
CMP0056 # export EXE_LINKER_FLAGS to try_run
CMP0057 # Support no if() IN_LIST operator
CMP0063 # Honor visibility properties for all targets
+ CMP0077 # Allow option() overrides in importing projects
)
if(POLICY ${p})
cmake_policy(SET ${p} NEW)