aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Fiselier <eric@efcs.ca>2015-02-19 16:38:30 -0500
committerEric Fiselier <eric@efcs.ca>2015-02-19 16:38:30 -0500
commit114886100bf10606409e9a7df78554a33cac29ef (patch)
tree694570e155e4fef71507b1369b8f68aa100b99d8 /CMakeLists.txt
parent9a118340486362072d0f26f1bec9199b80397866 (diff)
downloadgoogle-benchmark-114886100bf10606409e9a7df78554a33cac29ef.tar.gz
Don't use c++14
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 480d8a5..26fe76c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,14 +18,12 @@ include_directories(${source_dir}/include)
ExternalProject_Get_Property(googletest binary_dir)
link_directories(${binary_dir})
-# Enable the latest C++ standard possible
+# Try and enable C++11. Don't use C++14 because it doesn't work in some
+# configurations.
include(CheckCXXCompilerFlag)
-check_cxx_compiler_flag(--std=c++14 HAVE_FLAG_CXX_14)
check_cxx_compiler_flag(--std=c++11 HAVE_FLAG_CXX_11)
check_cxx_compiler_flag(--std=c++0x HAVE_FLAG_CXX_0X)
-if (HAVE_FLAG_CXX_14)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --std=c++14")
-elseif (HAVE_FLAG_CXX_11)
+if (HAVE_FLAG_CXX_11)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --std=c++11")
elseif (HAVE_FLAG_CXX_0X)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --std=c++0x")