aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAnton Danielsson <anton.danielsson@dirac.se>2015-10-05 14:36:09 +0200
committerAnton Danielsson <anton.danielsson@dirac.se>2015-10-08 10:48:29 +0200
commit53b1896c534ff6c643f4bfe4a2349bf80dfa5630 (patch)
tree92bcee055e818ccbd9777224089d4aefb3187ac9 /CMakeLists.txt
parent2589e69e0564269b4bebe55f7e82cd8bed4032a3 (diff)
downloadgoogle-benchmark-53b1896c534ff6c643f4bfe4a2349bf80dfa5630.tar.gz
Added _CRT_SECURE_NO_WARNINGS under MSVC.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 535e8e6..b799a62 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,7 +32,8 @@ endif()
# Turn compiler warnings up to 11
if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "MSVC")
- add_cxx_compiler_flag(-W4)
+ add_cxx_compiler_flag(-W4)
+ add_definitions(-D_CRT_SECURE_NO_WARNINGS)
else()
add_cxx_compiler_flag(-Wall)
endif()