aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEric <eric@efcs.ca>2016-09-05 15:48:40 -0600
committerGitHub <noreply@github.com>2016-09-05 15:48:40 -0600
commitd038472c18e7aa5b206896a9cd71b220b36b5eb8 (patch)
tree2e9f391e9715e4afe73dfe8a9c2792c03d1878c8 /CMakeLists.txt
parent9c261681266d051c0b04ddbe2064b569c8b19528 (diff)
downloadgoogle-benchmark-d038472c18e7aa5b206896a9cd71b220b36b5eb8.tar.gz
Refactor benchmark.cc into benchmark_register.cc and benchmark.cc (#287)
* Refactor benchmark.cc into benchmark_register.cc and benchmark_run.cc The benchmark.cc file is getting really big and it contains a bunch of unrelated components. This patch separates the files into two separate parts. The "runtime" parts and the "registration" parts. This patch also removes the PIMPL used by Benchmark. Previously we couldn't have STL types in the interface but now we can. Therefore there is no reason to keep BenchmarkImp. * add missing include * rework windows timers again * Guard timespec on older Windows versions * Remove old thread safety annotation workarounds
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 86f6142..dfa8a65 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -147,9 +147,14 @@ if (BENCHMARK_USE_LIBCXX)
endif(BENCHMARK_USE_LIBCXX)
# C++ feature checks
+# Determine the correct regular expression engine to use
cxx_feature_check(STD_REGEX)
cxx_feature_check(GNU_POSIX_REGEX)
cxx_feature_check(POSIX_REGEX)
+if(NOT HAVE_STD_REGEX AND NOT HAVE_GNU_POSIX_REGEX AND NOT HAVE_POSIX_REGEX)
+ message(FATAL_ERROR "Failed to determine the source files for the regular expression backend")
+endif()
+
cxx_feature_check(STEADY_CLOCK)
# Ensure we have pthreads
find_package(Threads REQUIRED)