aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Clarkson <mattyclarkson@gmail.com>2014-07-31 15:20:20 +0100
committerMatt Clarkson <mattyclarkson@gmail.com>2014-08-22 14:55:46 +0100
commitedfa60a1d12ab746e088c216fafbfc4d7a6c50e6 (patch)
treef22410f58671a266f9b4439cd45f688525631983 /CMakeLists.txt
parentfac16a662efb4ded79f74c795d81bdd688cb49a7 (diff)
downloadgoogle-benchmark-edfa60a1d12ab746e088c216fafbfc4d7a6c50e6.tar.gz
Resolve regular expression engines
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 80650c5..340055c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -77,6 +77,12 @@ message("-- Version: ${VERSION}")
set(GENERIC_LIB_VERSION ${VERSION})
string(SUBSTRING ${VERSION} 0 1 GENERIC_LIB_SOVERSION)
+# C++ feature checks
+include(CXXFeatureCheck)
+cxx_feature_check(STD_REGEX)
+cxx_feature_check(GNU_POSIX_REGEX)
+cxx_feature_check(POSIX_REGEX)
+
# Set up directories
include_directories(${PROJECT_SOURCE_DIR}/include)
include_directories(${PROJECT_SOURCE_DIR}/src)