aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarco Poletti <poletti.marco@gmail.com>2018-09-01 09:27:00 +0100
committerMarco Poletti <poletti.marco@gmail.com>2018-09-01 09:27:00 +0100
commit9fff407b3369f9ff855aa1a755d91084db3af8c3 (patch)
treef2324d384636be975de96bf82cae41ee2af5c9d0 /CMakeLists.txt
parentccd6a0adf79402994257db506ea65c8f15160cda (diff)
downloadgoogle-fruit-9fff407b3369f9ff855aa1a755d91084db3af8c3.tar.gz
Improve the Windows-only error message emitted when FRUIT_USES_BOOST was not disabled and BOOST_DIR is not set.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8adb84f..a549ba9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -61,7 +61,7 @@ set(FRUIT_USES_BOOST TRUE CACHE BOOL
if("${WIN32}" AND "${FRUIT_USES_BOOST}")
set(BOOST_DIR "" CACHE PATH "The directory where the boost library is installed, e.g. C:\\boost\\boost_1_62_0.")
if("${BOOST_DIR}" STREQUAL "")
- message(FATAL_ERROR "Please re-run CMake, specifying the boost library path as BOOST_DIR, e.g. -DBOOST_DIR=C:\\boost\\boost_1_62_0.")
+ message(FATAL_ERROR "Please re-run CMake, specifying the boost library path as BOOST_DIR, e.g. -DBOOST_DIR=C:\\boost\\boost_1_62_0, or specify -DFRUIT_USES_BOOST=False to not use boost.")
endif()
include_directories("${BOOST_DIR}")
endif()