aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMarco Poletti <poletti.marco@gmail.com>2016-05-14 09:20:05 +0100
committerMarco Poletti <poletti.marco@gmail.com>2016-05-14 09:21:22 +0100
commit0e7e5157c0b71b6078829b3ff63cf8b6723ec6b4 (patch)
tree14164d5519416f0f086f860d4234758b1fb925bd /tests/CMakeLists.txt
parentcc28070594d72e94171ef1e09bc9bf7dec189a37 (diff)
downloadgoogle-fruit-0e7e5157c0b71b6078829b3ff63cf8b6723ec6b4.tar.gz
Fix a bug that caused a compilation error when registering a factory of unique_ptr<C> when C was not copy-constructible.
Also add tests for the non-unique_ptr factory case now that those flows are no longer exercised by the unique_ptr factory tests. Fixes #14.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 78e6f6f..f5451df 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -33,6 +33,7 @@ explicit_provider_injection.cpp
explicit_provider_injection_with_annotation.cpp
factory_bindings.cpp
factory_bindings_error_abstract_class.cpp
+factory_bindings_notcopyable_ok.cpp
factory_bindings_with_annotation.cpp
incompatible_double_injection.cpp
incompatible_double_injection_with_annotations.cpp
@@ -143,6 +144,7 @@ register_factory_not_existing_constructor1.cpp
register_factory_not_existing_constructor1_with_annotation.cpp
register_factory_not_existing_constructor2.cpp
register_factory_not_existing_constructor2_with_annotation.cpp
+register_factory_notcopyable_ok.cpp
register_factory_with_annotation.cpp
register_factory_with_different_annotation.cpp
register_factory_with_different_annotation_error.cpp
@@ -169,6 +171,24 @@ register_provider_with_annotation.cpp
register_provider_with_annotations_malformed_signature.cpp
register_provider_with_binding_compression.cpp
register_provider_with_binding_compression_with_annotation.cpp
+register_value_factory_autoinject2.cpp
+register_value_factory_autoinject4.cpp
+register_value_factory_autoinject_annotation_in_signature_return_type.cpp
+register_value_factory_autoinject.cpp
+register_value_factory_autoinject_from_provider.cpp
+register_value_factory_autoinject_from_provider_with_annotation.cpp
+register_value_factory_autoinject_with_binding2.cpp
+register_value_factory_autoinject_with_binding.cpp
+register_value_factory_autoinject_with_binding_with_annotation.cpp
+register_value_factory_dep_on_provider.cpp
+register_value_factory_for_pointer.cpp
+register_value_factory_for_pointer_with_annotation.cpp
+register_value_factory_for_unique_pointer.cpp
+register_value_factory_for_unique_pointer_with_annotation.cpp
+register_value_factory_inconsistent_signature.cpp
+register_value_factory_not_existing_constructor2.cpp
+register_value_factory_not_existing_constructor2_with_annotation.cpp
+register_value_factory_with_annotation.cpp
semistatic_map_hash_selection.cpp
test1.cpp
type_alignment.cpp