aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMarco Poletti <poletti.marco@gmail.com>2015-12-01 23:14:12 +0100
committerMarco Poletti <poletti.marco@gmail.com>2015-12-01 23:14:12 +0100
commit34f5048e45634128d0d71e8087a0f3c786a5ea72 (patch)
tree71756dd4198a091b198fcc35523b97f0b550b316 /tests/CMakeLists.txt
parent0d2cef0bee989bcc08c60f06ae9ee839ac7a4634 (diff)
downloadgoogle-fruit-34f5048e45634128d0d71e8087a0f3c786a5ea72.tar.gz
Set the test timeout in CTest instead of using `timeout' directly.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 1327108..4dbfeaf 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -222,7 +222,7 @@ function(add_test_expected_to_fail_at_runtime NAME MESSAGE)
add_test(NAME ${NAME}
COMMAND bash -c "
F=`mktemp`
- if timeout 20s $<TARGET_FILE:${NAME}-exec> &>\${F}; then
+ if $<TARGET_FILE:${NAME}-exec> &>\${F}; then
cat \$F | fgrep error | head -n 1
rm -f \${F}
echo 'Expected runtime error but the test passed.'