aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMarco Poletti <poletti.marco@gmail.com>2016-10-16 16:35:10 +0100
committerMarco Poletti <poletti.marco@gmail.com>2016-10-16 16:35:10 +0100
commit4cf5205ce21c48ae815c7e38811b1ab9224e0c3a (patch)
tree6e3df6fb18ba291fef0598738a9702e0e979749b /tests/CMakeLists.txt
parent5498f4f5c7de37d6969ced6cc656eb859005506d (diff)
downloadgoogle-fruit-4cf5205ce21c48ae815c7e38811b1ab9224e0c3a.tar.gz
Fix various test failures due to the python test rewrite.
* Install python3, python3-nose2, python3-sh on OSX in Travis CI * Escape a backslash in tests/CMakeLists.txt, the CMake in Ubuntu 16.04 is ok with it but older versions of CMake fail at configure time. * Remove a memory leak in a test committed by mistake * Remove an obsolete import in the BUILD file for test (this caused an error when testing with Bazel).
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 60de88c..ea0390e 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -107,7 +107,7 @@ function(add_nose_based_fruit_tests DIRNAME)
COMMAND bash -c "
unset PYTHONPATH
unset PYTHONHOME
- cp ${CMAKE_CURRENT_SOURCE_DIR}/${TEST_SOURCE} ${CMAKE_CURRENT_BINARY_DIR} && \
+ cp ${CMAKE_CURRENT_SOURCE_DIR}/${TEST_SOURCE} ${CMAKE_CURRENT_BINARY_DIR} && \\
./${TEST_SOURCE}")
set_tests_properties(${NAME} PROPERTIES DEPENDS fruitlib-compile)
endforeach()