aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMarco Poletti <poletti.marco@gmail.com>2017-06-17 12:03:45 +0100
committerMarco Poletti <poletti.marco@gmail.com>2017-06-17 12:03:45 +0100
commit6b0ec358faedfd90b81ff759c439e8e072b85613 (patch)
tree2202d5fcd136f5e84058c95b20bda3c69ef9db5e /tests/CMakeLists.txt
parentfc9b19ac693c5504904bf9a18d3f99d935a3d31b (diff)
downloadgoogle-fruit-6b0ec358faedfd90b81ff759c439e8e072b85613.tar.gz
Skip the test_old_style_deprecation_error test on GCC 4.8.x, it doesn't work (the code compiles cleanly instead of reporting a deprecation warning).
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 58bcfbc..dfd7a27 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -102,6 +102,7 @@ file(GENERATE OUTPUT "${CMAKE_CURRENT_BINARY_DIR}/fruit_test_config.py"
CONTENT "
CXX='${CMAKE_CXX_COMPILER}'
CXX_COMPILER_NAME='${CMAKE_CXX_COMPILER_ID}'
+CXX_COMPILER_VERSION='${CMAKE_CXX_COMPILER_VERSION}'
FRUIT_COMPILE_FLAGS='${FRUIT_COMPILE_FLAGS} ${FRUIT_TESTONLY_CXXFLAGS}'
ADDITIONAL_LINKER_FLAGS='${CMAKE_EXE_LINKER_FLAGS}'
RUN_TESTS_UNDER_VALGRIND='${RUN_TESTS_UNDER_VALGRIND_FLAG}'