aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMarco Poletti <poletti.marco@gmail.com>2017-06-17 16:05:17 +0100
committerMarco Poletti <poletti.marco@gmail.com>2017-06-17 16:05:17 +0100
commitbee4d5afa6fabdd1c64b7281822459692aa3ebb6 (patch)
tree67d4604694ee2ab9b2e08a5fb673813786f97383 /tests/CMakeLists.txt
parent3e21dcf3de08de7a9e1dbb8ff419b4bea2da9f54 (diff)
downloadgoogle-fruit-bee4d5afa6fabdd1c64b7281822459692aa3ebb6.tar.gz
Various test fixes:
* Run tests expected to fail under Valgrind too * When compiling/executing something, print the executable and arguments first, so that it's easy to reproduce the issue manually * Print stdout/stderr when a compilation/execution succeeds too, to help debugging (especially for cases where we expected an error) * Add the built Fruit library's directory to PATH on Windows, fixing "fruit.dll not found" errors.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index dfd7a27..fed976e 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -104,6 +104,7 @@ CXX='${CMAKE_CXX_COMPILER}'
CXX_COMPILER_NAME='${CMAKE_CXX_COMPILER_ID}'
CXX_COMPILER_VERSION='${CMAKE_CXX_COMPILER_VERSION}'
FRUIT_COMPILE_FLAGS='${FRUIT_COMPILE_FLAGS} ${FRUIT_TESTONLY_CXXFLAGS}'
+ADDITIONAL_INCLUDE_DIRS='${BOOST_DIR}'
ADDITIONAL_LINKER_FLAGS='${CMAKE_EXE_LINKER_FLAGS}'
RUN_TESTS_UNDER_VALGRIND='${RUN_TESTS_UNDER_VALGRIND_FLAG}'
VALGRIND_FLAGS='${VALGRIND_FLAGS_STR}'