aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMarco Poletti <poletti.marco@gmail.com>2016-07-12 15:42:48 +0100
committerMarco Poletti <poletti.marco@gmail.com>2016-07-12 15:42:48 +0100
commitbf1001594120b2f9458151d058fd2f13a6e565b4 (patch)
tree7d35dc6ce5891d256c6afee6f72e1abfee8727be /tests/CMakeLists.txt
parent549e7d4298a43f9497bd69e4261c1911813d33c1 (diff)
downloadgoogle-fruit-bf1001594120b2f9458151d058fd2f13a6e565b4.tar.gz
Correctly set ASAN_OPTIONS in tests as desired.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index ac772a4..967f8bb 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -263,9 +263,6 @@ function(add_successful_compile NAME)
set_tests_properties(${NAME} PROPERTIES DEPENDS ${BUILD})
endfunction(add_successful_compile)
-# Build shared libraries by default
-set(ASAN_OPTIONS "" CACHE STRING "Asan options (only relevant when running Fruit tests with Asan)." FORCE)
-
function(add_test_expected_to_pass NAME)
if (${RUN_TESTS_UNDER_VALGRIND})
# Re-add --show-leak-kinds=all here once Travis CI will have a new-enough version of valgrind.
@@ -275,7 +272,6 @@ function(add_test_expected_to_pass NAME)
else()
add_test(NAME ${NAME}
COMMAND ${TIMEOUT_COMMAND_PREFIX} $<TARGET_FILE:${NAME}-exec>)
- set_tests_properties(${NAME} PROPERTIES ENVIRONMENT "ASAN_OPTIONS=${ASAN_OPTIONS}")
endif()
add_successful_compile(${NAME})
endfunction(add_test_expected_to_pass)