aboutsummaryrefslogtreecommitdiff
path: root/ink_stroke_modeler/internal/prediction/kalman_filter/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ink_stroke_modeler/internal/prediction/kalman_filter/CMakeLists.txt')
-rw-r--r--ink_stroke_modeler/internal/prediction/kalman_filter/CMakeLists.txt54
1 files changed, 54 insertions, 0 deletions
diff --git a/ink_stroke_modeler/internal/prediction/kalman_filter/CMakeLists.txt b/ink_stroke_modeler/internal/prediction/kalman_filter/CMakeLists.txt
new file mode 100644
index 0000000..2661a10
--- /dev/null
+++ b/ink_stroke_modeler/internal/prediction/kalman_filter/CMakeLists.txt
@@ -0,0 +1,54 @@
+# Copyright 2022 Google LLC
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+ink_cc_library(
+ NAME
+ matrix
+ HDRS
+ matrix.h
+)
+
+ink_cc_test(
+ NAME
+ matrix_test
+ SRCS
+ matrix_test.cc
+ DEPS
+ matrix
+ GTest::gmock_main
+)
+
+ink_cc_library(
+ NAME
+ kalman_filter
+ SRCS
+ axis_predictor.cc
+ kalman_filter.cc
+ HDRS
+ axis_predictor.h
+ kalman_filter.h
+ DEPS
+ matrix
+ absl::memory
+)
+
+ink_cc_test(
+ NAME
+ axis_predictor_test
+ SRCS
+ axis_predictor_test.cc
+ DEPS
+ kalman_filter
+ GTest::gmock_main
+)