aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBruce A. Mah <bmah@es.net>2015-01-06 10:22:00 -0800
committerBruce A. Mah <bmah@es.net>2015-01-06 10:22:00 -0800
commit3b60f09017c1733882e9245d13922310c0a83c9f (patch)
treeb70108b399875154090647bf99ac91a80f11e7a3 /configure.ac
parent4874c4a88b0d87e642947fa9972df6d8a5bb788f (diff)
downloadiperf3-3b60f09017c1733882e9245d13922310c0a83c9f.tar.gz
Unbreak (partially) SCTP on Solaris.
Solaris implements an (older?) version of the API for SCTP_MAXSEG, which takes an integer argument rather than a struct sctp_assoc_val. We need to test for that and handle it appropriately. There are some signs it doesn't even work correctly if we do this, so quietly ignore errors that happen if the OS complains it's unsupported. Also, Solaris doesn't support SCTP_DISABLE_FRAGMENTS even though it defines the preprocessor symbol for this. Rather than aborting when we try to unsuccessfully unset this option, just ignore the error. Lightly tested with SCTP over IPv6 on localhost.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6f1f110..31361b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,7 @@
# Initialize the autoconf system for the specified tool, version and mailing list
AC_INIT(iperf, 3-CURRENT, https://github.com/esnet/iperf, iperf, http://software.es.net/iperf/)
+AC_LANG(C)
# Specify where the auxiliary files created by configure should go. The config
# directory is picked so that they don't clutter up more useful directories.
@@ -88,6 +89,7 @@ AC_CHECK_HEADERS([sys/socket.h])
AC_CHECK_HEADERS([netinet/sctp.h],
AC_DEFINE([HAVE_SCTP], [1], [Have SCTP support.])
AC_SEARCH_LIBS(sctp_bindx, [sctp]),
+ AC_CHECK_TYPES([struct sctp_assoc_value])
[],
[#ifdef HAVE_SYS_SOCKET_H
#include <sys/socket.h>