aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBruce A. Mah <bmah@kitchenlab.org>2017-08-15 11:13:08 -0700
committerGitHub <noreply@github.com>2017-08-15 11:13:08 -0700
commit4a45b32b4770f22e37dde22cce16dbc76a0ea9b6 (patch)
tree92a1920b261ea6ff0d0dba01f10c90860ba263c8 /configure.ac
parent7cf95d205d18d910e622145584a04ac18aca55ba (diff)
downloadiperf3-4a45b32b4770f22e37dde22cce16dbc76a0ea9b6.tar.gz
Fix out-of-the-box builds with no OpenSSL (#633)
Don't make OpenSSL detection error out unless --with-openssl explicitly given. This fixes the out-of-the-box build on macOS, which doesn't include headers, etc. for OpenSSL by default. The configure script still errors out if the user specifies a --with-openssl flag but for some reason the build host's OpenSSL is broken or can't be used. * Regen.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 79f3869..54e0e66 100644
--- a/configure.ac
+++ b/configure.ac
@@ -107,7 +107,9 @@ else
# Check for OPENSSL support
AX_CHECK_OPENSSL(
[ AC_DEFINE([HAVE_SSL], [1], [OpenSSL Is Available]) ],
- [ AC_MSG_FAILURE([--with-openssl was given, but test for openssl failed]) ]
+ [ if test "x$with_openssl" != "x"; then
+ AC_MSG_FAILURE([--with-openssl was given, but test for OpenSSL failed])
+ fi ]
)
LDFLAGS="$LDFLAGS $OPENSSL_LDFLAGS"
LIBS="$OPENSSL_LIBS $LIBS"