aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBruce A. Mah <bmah@es.net>2014-05-19 15:22:08 -0700
committerBruce A. Mah <bmah@es.net>2014-05-19 15:22:08 -0700
commit94c0bfffcb9b79370af3e445a813131359a806e4 (patch)
tree0cd7c697bf85bfc48452204a81738d6bed95537a /configure.ac
parent99b5861c22f1b9728237c5336a390ec7077d32d3 (diff)
downloadiperf3-94c0bfffcb9b79370af3e445a813131359a806e4.tar.gz
Another try at portability. Don't do -Werror. While probably
the best thing to do from a code hygeine standpoint, it's too painful to try to get right for now. Fixes #174 (second try).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 5bbc0dd..4650755 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,11 +20,9 @@ AC_PROG_RANLIB
AC_PROG_LN_S
AC_PROG_LIBTOOL
-# Add -Wall -Werror if we are using GCC.
-# We also need -Wno-deprecated-declarations, primarily because on MacOS, daemon(3)
-# is deprecated starting from MacOS 10.5.
+# Add -Wall if we are using GCC.
if test "x$GCC" = "xyes"; then
- CFLAGS="$CFLAGS -Wall -Werror -Wno-deprecated-declarations"
+ CFLAGS="$CFLAGS -Wall"
fi
# Checks for header files.