aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBruce A. Mah <bmah@es.net>2015-01-05 15:19:57 -0800
committerBruce A. Mah <bmah@es.net>2015-01-05 15:19:57 -0800
commite1420625725acda6507a667758bbcbfd0b2b295b (patch)
tree8b67844162544fc6d0731c33b96ec06bfb5d20d0 /configure.ac
parenteb9a2c07c3cc3d9e555dbf8a0ab807c50324d071 (diff)
downloadiperf3-e1420625725acda6507a667758bbcbfd0b2b295b.tar.gz
Add -X to restrict SCTP binding to a subset of interfaces.
Contains an alternate implementation of previously-submitted patches to set the maximum segment size and no-delay options. As a result of this change, SCTP functionality on Linux will generally require the libsctp library (on CentOS and similar distributions this is provided by the lksctp-tools RPM). Part of #131. Submitted by: Bruce Simpson <bs48@st-andrews.ac.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 50b4819..6f1f110 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# iperf, Copyright (c) 2014, The Regents of the University of
+# iperf, Copyright (c) 2014, 2015, The Regents of the University of
# California, through Lawrence Berkeley National Laboratory (subject
# to receipt of any required approvals from the U.S. Dept. of
# Energy). All rights reserved.
@@ -86,7 +86,8 @@ AC_C_CONST
# Check for SCTP support
AC_CHECK_HEADERS([sys/socket.h])
AC_CHECK_HEADERS([netinet/sctp.h],
- AC_DEFINE([HAVE_SCTP], [1], [Have SCTP support.]),
+ AC_DEFINE([HAVE_SCTP], [1], [Have SCTP support.])
+ AC_SEARCH_LIBS(sctp_bindx, [sctp]),
[],
[#ifdef HAVE_SYS_SOCKET_H
#include <sys/socket.h>