aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorjef <jef@odev-vm-4.es.net>2012-10-26 07:45:28 -0700
committerjef <jef@odev-vm-4.es.net>2012-10-26 07:45:28 -0700
commit53a87a0b9dda1f6f80ac8c87a966f0808970911a (patch)
tree6facb69a40516d95bde3231aabc005eefe52fe0c /src/Makefile.am
parentea71aaeaeeeee91cd91ec4dc68cfa3d963e0664e (diff)
downloadiperf3-53a87a0b9dda1f6f80ac8c87a966f0808970911a.tar.gz
Oops, -lm is still needed by cjson for floor(). Still worth getting
rid of pow() though.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5fc5c1c..675c530 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -36,7 +36,7 @@ libiperf_a_SOURCES = \
# Specify the sources and various flags for the iperf binary
iperf3_SOURCES = main.c
iperf3_CFLAGS = -g -Wall
-iperf3_LDADD = libiperf.a
+iperf3_LDADD = libiperf.a -lm
iperf3_LDFLAGS =
# Specify the sources and various flags for the profiled iperf binary. This
@@ -45,7 +45,7 @@ iperf3_profile_SOURCES = main.c \
$(libiperf_a_SOURCES)
iperf3_profile_CFLAGS = -pg -Wall
-iperf3_profile_LDADD = libiperf.a
+iperf3_profile_LDADD = libiperf.a -lm
iperf3_profile_LDFLAGS =
# Specify the sources and various flags for the test cases