aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRollingSlack <8922964+rollingslack@users.noreply.github.com>2018-08-09 15:36:54 -0400
committerBruce A. Mah <bmah@kitchenlab.org>2018-08-09 12:36:54 -0700
commitbeac6881e6ee053ef7847793d67ec155156fa63f (patch)
treee3250a0b376479c4493421279b1081c72ee6dcbb /src/Makefile.am
parentf64da9b9bc8c4aeab9a031b75c992ad2a13d6b5b (diff)
downloadiperf3-beac6881e6ee053ef7847793d67ec155156fa63f.tar.gz
Add libiperf api for getting iperf version (#767)
Also includes a test program.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ef7b66a..e95722d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,9 +1,9 @@
lib_LTLIBRARIES = libiperf.la # Build and install an iperf library
bin_PROGRAMS = iperf3 # Build and install an iperf binary
if ENABLE_PROFILING
-noinst_PROGRAMS = t_timer t_units t_uuid iperf3_profile # Build, but don't install the test programs and a profiled version of iperf3
+noinst_PROGRAMS = t_timer t_units t_uuid t_api iperf3_profile # Build, but don't install the test programs and a profiled version of iperf3
else
-noinst_PROGRAMS = t_timer t_units t_uuid # Build, but don't install the test programs
+noinst_PROGRAMS = t_timer t_units t_uuid t_api # Build, but don't install the test programs
endif
include_HEADERS = iperf_api.h # Defines the headers that get installed with the program
@@ -77,6 +77,10 @@ t_uuid_CFLAGS = -g
t_uuid_LDFLAGS =
t_uuid_LDADD = libiperf.la
+t_api_SOURCES = t_api.c
+t_api_CFLAGS = -g
+t_api_LDFLAGS =
+t_api_LDADD = libiperf.la
@@ -84,6 +88,7 @@ t_uuid_LDADD = libiperf.la
TESTS = \
t_timer \
t_units \
- t_uuid
+ t_uuid \
+ t_api
dist_man_MANS = iperf3.1 libiperf.3