aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAaronMatthewBrown <devnull@localhost>2009-12-08 21:36:24 +0000
committerAaronMatthewBrown <devnull@localhost>2009-12-08 21:36:24 +0000
commitf4a3ddaae6e4e7f0f6f5f2128ad4d87ea0f87121 (patch)
treea7461af2e395a6eead7f4eb85c36d822e209f2af /src/Makefile.am
parentd768f73dcef0741ffeb69b467fc7759d78d99b10 (diff)
downloadiperf3-f4a3ddaae6e4e7f0f6f5f2128ad4d87ea0f87121.tar.gz
Add an initial autotools setup.
The main iperf binary is compiled, along with a static libiperf, the unit tests, and a profiled iperf binary. The tests, and the profiled iperf binary do not get installed. To compile, run: ./bootstrap.sh ./configure make It has all the normal make options (they come mostly for free). e.g.: You can run "make install" to install it. You can run "make dist" which will create a distribution tarball. You can run "make check" to run all the tests. I backed up the existing Makefile as "src/Makefile.old" in case folks want to use that still.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am107
1 files changed, 107 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..d2a10fe
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,107 @@
+lib_LIBRARIES = libiperf.a # Build and install a static iperf library
+bin_PROGRAMS = iperf3 # Build and install an iperf binary
+noinst_PROGRAMS = t_timer t_units t_uuid iperf3_profile # Build, but don't install the test programs and a profiled version of iperf3
+include_HEADERS = iperf_api.h iperf_server_api.h # Defines the headers that get installed with the program
+
+
+# Specify the source files and flags for the iperf library
+libiperf_a_SOURCES = \
+ iperf_api.c \
+ iperf_server_api.c \
+ iperf_tcp.c \
+ iperf_udp.c \
+ timer.c \
+ net.c \
+ tcp_window_size.c \
+ units.c \
+ uuid.c \
+ tcp_info.c \
+ locale.c \
+ iperf_api.h \
+ iperf.h \
+ iperf_server_api.h \
+ iperf_tcp.h \
+ iperf_udp.h \
+ locale.h \
+ net.h \
+ tcp_window_size.h \
+ timer.h \
+ units.h \
+ uuid.h \
+ version.h
+libiperf_a_CFLAGS = -I../include
+
+# Specify the sources and various flags for the iperf binary
+iperf3_SOURCES = main.c
+iperf3_CFLAGS = -g -Wall
+iperf3_LDADD = libiperf.a
+
+# Linux installs require the uuid library explicitly linked in
+if LINUX
+iperf3_LDFLAGS = -luuid
+else
+iperf3_LDFLAGS =
+endif
+
+# Specify the sources and various flags for the profiled iperf binary. This
+# binary recompiles all the source files to make sure they are all profiled.
+iperf3_profile_SOURCES = main.c \
+ iperf_api.c \
+ iperf_server_api.c \
+ iperf_tcp.c \
+ iperf_udp.c \
+ timer.c \
+ net.c \
+ tcp_window_size.c \
+ units.c \
+ uuid.c \
+ tcp_info.c \
+ locale.c \
+ iperf_api.h \
+ iperf.h \
+ iperf_server_api.h \
+ iperf_tcp.h \
+ iperf_udp.h \
+ locale.h \
+ net.h \
+ tcp_window_size.h \
+ timer.h \
+ units.h \
+ uuid.h \
+ version.h
+iperf3_profile_CFLAGS = -pg -Wall
+iperf3_profile_LDADD = libiperf.a
+
+# Linux installs require the uuid library explicitly linked in
+if LINUX
+iperf3_profile_LDFLAGS = -luuid
+else
+iperf3_profile_LDFLAGS =
+endif
+
+# Specify the sources and various flags for the test cases
+t_timer_SOURCES = t_timer.c
+t_timer_CFLAGS = -g -Wall
+t_timer_LDFLAGS =
+t_timer_LDADD = libiperf.a
+
+t_units_SOURCES = t_units.c
+t_units_CFLAGS = -g -Wall
+t_units_LDFLAGS =
+t_units_LDADD = libiperf.a
+
+t_uuid_SOURCES = t_uuid.c
+t_uuid_CFLAGS = -g -Wall
+t_uuid_LDFLAGS =
+t_uuid_LDADD = libiperf.a
+
+
+
+
+# Specify which tests to run during a "make check"
+TESTS = \
+ t_timer \
+ t_units \
+ t_uuid
+
+dist_man1_MANS = iperf.1