aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorsethdelliott <devnull@localhost>2010-07-19 20:38:40 +0000
committersethdelliott <devnull@localhost>2010-07-19 20:38:40 +0000
commit01ca972b6cfee8e51bd44072030b607bb4452078 (patch)
treeaba994728091e0d23093472ce1befbae43304a19 /src/Makefile.am
parent8430ad49e64446668b1305341129e173dc3c2eb0 (diff)
downloadiperf3-01ca972b6cfee8e51bd44072030b607bb4452078.tar.gz
Updated autoconf stuff and fixed a small error with ierror()
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am49
1 files changed, 15 insertions, 34 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index bbd3ff6..d744e61 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,28 +6,30 @@ include_HEADERS = iperf_api.h iperf_server_api.h # Define
# Specify the source files and flags for the iperf library
libiperf_a_SOURCES = \
+ iperf.h \
iperf_api.c \
+ iperf_api.h \
+ iperf_error.c \
+ iperf_error.h \
iperf_server_api.c \
+ iperf_server_api.h \
iperf_tcp.c \
+ iperf_tcp.h \
iperf_udp.c \
- timer.c \
- net.c \
- tcp_window_size.c \
- units.c \
+ iperf_udp.h \
iperf_util.c \
- tcp_info.c \
+ iperf_util.h \
locale.c \
- iperf_api.h \
- iperf.h \
- iperf_server_api.h \
- iperf_tcp.h \
- iperf_udp.h \
locale.h \
+ net.c \
net.h \
+ tcp_info.c \
+ tcp_window_size.c \
tcp_window_size.h \
+ timer.c \
timer.h \
+ units.c \
units.h \
- iperf_util.h \
version.h
# Specify the sources and various flags for the iperf binary
@@ -45,29 +47,8 @@ endif
# Specify the sources and various flags for the profiled iperf binary. This
# binary recompiles all the source files to make sure they are all profiled.
iperf3_profile_SOURCES = main.c \
- iperf_api.c \
- iperf_server_api.c \
- iperf_tcp.c \
- iperf_udp.c \
- timer.c \
- net.c \
- tcp_window_size.c \
- units.c \
- iperf_util.c \
- tcp_info.c \
- locale.c \
- iperf_api.h \
- iperf.h \
- iperf_server_api.h \
- iperf_tcp.h \
- iperf_udp.h \
- locale.h \
- net.h \
- tcp_window_size.h \
- timer.h \
- units.h \
- iperf_util.h \
- version.h
+ $(libiperf_a_SOURCES)
+
iperf3_profile_CFLAGS = -pg -Wall
iperf3_profile_LDADD = libiperf.a