aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJon Dugan <jdugan@x1024.net>2008-03-12 20:28:21 +0000
committerJon Dugan <jdugan@x1024.net>2008-03-12 20:28:21 +0000
commit1efd8f8c50ba0f309c48a4a2941a7348bfb5c112 (patch)
treeef987ce0d0e72983f6a10314caba53b3c3c5c40f /src/Makefile.am
parentc230011976f99c96328e74b4aebd652ba24f7e59 (diff)
downloadiperf3-1efd8f8c50ba0f309c48a4a2941a7348bfb5c112.tar.gz
2008-03-12 Jon Dugan <jdugan@x1024.net>
* Added -Wall to CXXFLAGS and CFLAGS. This generated a lot of noise in the autotools generated files. * Added initial AUTHORS file. This is incomplete, but it's a start. 2008-03-12 Andrew Gallatin <gallatin@gmail.com> * Rework threading. This is done by having a condition variable for the reporting thread rather than using sched_yield and/or usleep. * Address performance issues on non Linux systems by avoiding system calls which are expensive on platforms other than Linux. * Fixes from FreeBSD ports: max_size_t is now 64 bits and not Iperf does not exit on ENOBUFS.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 467d246..7efb598 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -9,6 +9,9 @@ AM_CPPFLAGS = @STRIP_BEGIN@ \
-I$(top_builddir)/include \
@STRIP_END@
+AM_CXXFLAGS = -Wall
+AM_CFLAGS = -Wall
+
iperf_LDFLAGS = @CFLAGS@ @PTHREAD_CFLAGS@ @WEB100_CFLAGS@ @DEFS@
iperf_SOURCES = \