aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorjef <jef@odev-vm-4.es.net>2012-08-10 12:43:50 -0700
committerjef <jef@odev-vm-4.es.net>2012-08-10 12:43:50 -0700
commit2ab386bf134e9d963008e5395c924c4ac7d084ed (patch)
treedbfb957c021f1e69925d0c6295d03ffbef5e9062 /src/Makefile.am
parent7590fc8d16aa4475573446b7ae427675de1e0209 (diff)
downloadiperf3-2ab386bf134e9d963008e5395c924c4ac7d084ed.tar.gz
Got rid of libuuid stuff, for portability.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 0 insertions, 12 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index eb98078..aa4429d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -38,13 +38,7 @@ libiperf_a_SOURCES = \
iperf3_SOURCES = main.c
iperf3_CFLAGS = -g -Wall
iperf3_LDADD = libiperf.a
-
-# Linux installs require the uuid library explicitly linked in
-if USE_UUID_LIBRARY
-iperf3_LDFLAGS = -luuid
-else
iperf3_LDFLAGS =
-endif
# Specify the sources and various flags for the profiled iperf binary. This
# binary recompiles all the source files to make sure they are all profiled.
@@ -53,13 +47,7 @@ iperf3_profile_SOURCES = main.c \
iperf3_profile_CFLAGS = -pg -Wall
iperf3_profile_LDADD = libiperf.a
-
-# Linux installs require the uuid library explicitly linked in
-if USE_UUID_LIBRARY
-iperf3_profile_LDFLAGS = -luuid
-else
iperf3_profile_LDFLAGS =
-endif
# Specify the sources and various flags for the test cases
t_timer_SOURCES = t_timer.c