aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorjef <jef@odev-vm-4.es.net>2012-09-28 16:00:14 -0700
committerjef <jef@odev-vm-4.es.net>2012-09-28 16:00:14 -0700
commit98ce496b1b75dcbfd4c21962fa4e5d898bf7930b (patch)
tree0b4c2c568f00fd32153d1d0495fa5638ec03a6f7 /src/Makefile.am
parent56a97f9337a8557e68d48a7b5127be2199454dbd (diff)
downloadiperf3-98ce496b1b75dcbfd4c21962fa4e5d898bf7930b.tar.gz
Some changes to the iperf3 API to work with bwctl, mostly having to
do with what defs are in which include file. End result is we now have only one public include file, iperf_api.h.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index aa4429d..8a3ffca 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,7 +1,7 @@
lib_LIBRARIES = libiperf.a # Build and install a static iperf library
bin_PROGRAMS = iperf3 # Build and install an iperf binary
noinst_PROGRAMS = t_timer t_units t_uuid iperf3_profile # Build, but don't install the test programs and a profiled version of iperf3
-include_HEADERS = iperf_api.h iperf_error.h iperf_client_api.h iperf_server_api.h # Defines the headers that get installed with the program
+include_HEADERS = iperf_api.h # Defines the headers that get installed with the program
# Specify the source files and flags for the iperf library
@@ -10,11 +10,8 @@ libiperf_a_SOURCES = \
iperf_api.c \
iperf_api.h \
iperf_error.c \
- iperf_error.h \
- iperf_client_api.c \
- iperf_client_api.h \
+ iperf_client_api.c \
iperf_server_api.c \
- iperf_server_api.h \
iperf_tcp.c \
iperf_tcp.h \
iperf_udp.c \