aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorjef <jef@odev-vm-4.es.net>2012-10-15 09:49:20 -0700
committerjef <jef@odev-vm-4.es.net>2012-10-15 09:49:20 -0700
commita497129b4d3aa867f3d3558eb865bd08b3f5598d (patch)
tree6df938c216d0d5a30d128549e9f6539f5aaeeca2 /src/Makefile.am
parent249ca84944b019063cfd0a276041607155897b7a (diff)
downloadiperf3-a497129b4d3aa867f3d3558eb865bd08b3f5598d.tar.gz
Oops, the cjson files need to be in the src directory.
Also changed the makefiles so that cjson gets compiled and linked in. Next step: actually call it.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8a3ffca..8101ce0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,6 +6,8 @@ include_HEADERS = iperf_api.h # Defines the headers that get installed w
# Specify the source files and flags for the iperf library
libiperf_a_SOURCES = \
+ cjson.c \
+ cjson.h \
iperf.h \
iperf_api.c \
iperf_api.h \
@@ -43,7 +45,7 @@ iperf3_profile_SOURCES = main.c \
$(libiperf_a_SOURCES)
iperf3_profile_CFLAGS = -pg -Wall
-iperf3_profile_LDADD = libiperf.a
+iperf3_profile_LDADD = libiperf.a -lm
iperf3_profile_LDFLAGS =
# Specify the sources and various flags for the test cases