aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 5bbc0dd..4650755 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,11 +20,9 @@ AC_PROG_RANLIB
AC_PROG_LN_S
AC_PROG_LIBTOOL
-# Add -Wall -Werror if we are using GCC.
-# We also need -Wno-deprecated-declarations, primarily because on MacOS, daemon(3)
-# is deprecated starting from MacOS 10.5.
+# Add -Wall if we are using GCC.
if test "x$GCC" = "xyes"; then
- CFLAGS="$CFLAGS -Wall -Werror -Wno-deprecated-declarations"
+ CFLAGS="$CFLAGS -Wall"
fi
# Checks for header files.